Skocz do zawartości


tablety.pl
Zdjęcie

Windows Update i błąd 80070490




  • Zaloguj się, aby dodać odpowiedź
18 odpowiedzi w tym temacie

#1 Orlin

Orlin

    First Rank

  • Użytkownicy
  • 30 postów
  • Płeć:Mężczyzna
  • Lokalizacja:PL

Napisano 07 07 2009 - 19:45

Mniej więcej od czasu zainstalowania SP2 w Viście HP x64 PL (zainstalowany dopiero, gdy się pojawił w Windows Update - nie instalowałem go wcześniej ręcznie) nie chcą mi się zainstalować 4 poprawki - 3 aktualizacje zabezpieczeń (KB961501, KB970238, KB968537) oraz zbiorcza poprawka programu Media Center (KB967632) - wszystkie opublikowane wg WU 2009-06-09 - ale wcześniej mi się jakoś nie wyświetlały. Vista na laptopie działa od 2009-06-15 i pobrała wtedy mnóstwo innych aktualizacji, które zainstalowały się bez problemu, później pobrało jeszcze jakieś i je też zainstalowało. Wirusów na 99,99% nie ma (skanowane przez NOD32, wcześniej NIS 2008, komputer za routerem, żadne podejrzane, ani dyskusyjnie legalne programy nie były uruchamiane / instalowane, strony odwiedzane tylko te "grzeczne", żadnych podejrzanych usług i programów uruchamianych przy starcie systemu i po zalogowaniu się nie widzę.
No i teraz cały czas wyskakuje komunikat, że mam 4 aktualizacje do zainstalowania, ale ich instalacja zawsze kończy się niepowodzeniem (z kodem błędu 80070490 - Rozszerzenie WU napotkało nieznany bład). Próbowałem wyłączyć antywirusa, restartować usługę WUpdate, zainstalować zgodnie z wygooglanymi radami: windowsupdateagent30-x64.exe (bez efektu) oraz Windows6.0-KB947821-v4-x64.msu (komunikat, że nie ma zastosowania dla tego systemu, czy coś w tym stylu).
Nie próbowałem jeszcze odinstalowywania SP2, ani przywracania systemu (do stanu sprzed 7 dni, kiedy się zainstalował SP2) i nie próbowałem naprawy systemu z pomocą płytki Recovery - bo liczyłem na znalezienie mniej "inwazyjnych" metod. Jakieś pomysły, co może być przyczyną? Jak rozwiązać problem?
Jeszcze może dorzucę zawartość WindowsUpdate.log i CBS.log z ostatniej próby instalacji:
http://members.lycos...asyurl/wupdate/

Pozdrawiam,
Mirek

#2 Gość_picasso_*

Gość_picasso_*
  • Goście

Napisano 07 07 2009 - 19:54

Windows6.0-KB947821-v4-x64.msu (komunikat, że nie ma zastosowania dla tego systemu, czy coś w tym stylu)


+

2009-07-07 20:05:03, Error				 CBS	Failed to resolve Package: Package_for_KB968537_winpesrv~31bf3856ad364e35~amd64~~6.0.1.2. hr: 0x80070490
2009-07-07 20:05:03, Error				 CBS	Failed to resolve child of Package: Package_for_KB968537~31bf3856ad364e35~amd64~~6.0.1.2. hr: 0x80070490

Hmmm, może spróbujmy z tego: KLIK.

1. Utwórz ręcznie punkt Przywracania przed ingerencją.

2. Wytypuj w kluczu HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing wpisy relatywne do tych 4 łat. I je skasuj. Jeśli się okaże, że dany wpis nie ma stosownych uprawnień, trzeba będzie je ręcznie wyresetować.

3. Można jeszcze spróbować reset zabezpieczeń do poziomu domyślnego przez Fix-It z przyklejonego.



.

#3 Flavius

Flavius

    Expert Rank

  • Na emeryturze
  • 3769 postów
  • Płeć:Mężczyzna

Napisano 07 07 2009 - 20:52

3. Można jeszcze spróbować reset zabezpieczeń do poziomu domyślnego przez Fix-It z przyklejonego.

Jaki tam specjalny reset uprawnień :unsure: -to jest stary,znany reset uprawnień z secedit http://support.microsoft.com/kb/313222
-tylko teraz dozbrojony automat i nic więcej :P

No cóż tego co proponuje dosłownie autor bloga nie da się wykonać na x64

1.Subinacl nie obsługuje 64- bitowego kodu,trzeba by było się posłużyć SetACL aby zrobić dokładnie to samo co chce autor tego bloga
2.Gdybyśmy to zrobili dosłownie i tak byśmy naruszyli domyślne zabezpieczenia :rolleyes: - więc to tylko ostateczność...
Głos Opozycji Forumowej

#4 Gość_picasso_*

Gość_picasso_*
  • Goście

Napisano 07 07 2009 - 20:59

Jaki tam specjalny reset uprawnień laugh.gif -to jest stary,znany reset uprawnień z secedit http://support.microsoft.com/kb/313222
-tylko teraz dozbrojony automat i nic więcej


Oczywiście, a Ty masz najwyraźniej jakiś problem nie wiadomo z czym. Doskonale wiem o tym - opis w przyklejonym mówi sam za siebie. :rolleyes:

No cóż tego co proponuje dosłownie autor bloga nie da się wykonać na x64


Dlatego podałam co innego, również i z powodu naruszenia naturalnego układu zabezpieczeń.



.

#5 Orlin

Orlin

    First Rank

  • Użytkownicy
  • 30 postów
  • Płeć:Mężczyzna
  • Lokalizacja:PL

Napisano 07 07 2009 - 22:33

Hmmm, może spróbujmy z tego: KLIK.

1. Utwórz ręcznie punkt Przywracania przed ingerencją.

2. Wytypuj w kluczu HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing wpisy relatywne do tych 4 łat. I je skasuj. Jeśli się okaże, że dany wpis nie ma stosownych uprawnień, trzeba będzie je ręcznie wyresetować.

3. Można jeszcze spróbować reset zabezpieczeń do poziomu domyślnego przez Fix-It z przyklejonego.


Po pierwsze dzięki za tak szybkie odpowiedzi :-)
Ździebko się tylko pogubiłem z tymi wszystkim setACL, subinacl, secedit.
Wykonałem punkt 1., przy 2. wyskakuje okienko:
"Błąd przy usuwaniu klucza"
"Nie można usunąć Package_for_KB961501~31bf3856ad364e35~amd64~~6.0.1.1: błąd przy usuwaniu klucza."

Z wyresetowaniem uprawnień - tak jak napisałem - pogubiłem się, więc zastosowałem ten Fix-It. Wykonał się bez błędów, ale klucza nadal nie mogę wywalić...
No i WU nadal wywala ten sam błąd.

Pozdr.,
Mirek

#6 Gość_picasso_*

Gość_picasso_*
  • Goście

Napisano 07 07 2009 - 22:35

Wykonałem punkt 1., przy 2. wyskakuje okienko:
"Błąd przy usuwaniu klucza"
"Nie można usunąć Package_for_KB961501~31bf3856ad364e35~amd64~~6.0.1.1: błąd przy usuwaniu klucza."


Dlatego mówiłam:

Jeśli się okaże, że dany wpis nie ma stosownych uprawnień, trzeba będzie je ręcznie wyresetować.


Ręcznie oznacza instrukcję z Wirusów: KLIK. Przepisanie Właściciela klucza na Administratorów + przyznanie Administratorom Pełnej kontroli + i dopiero wtedy kasacja. Uwzględnij opcję rekursywną, by resetowało również podobiekty danego klucza.

Z wyresetowaniem uprawnień - tak jak napisałem - pogubiłem się, więc zastosowałem ten Fix-It. Wykonał się bez błędów, ale klucza nadal nie mogę wywalić...


Bo to nie miało być zamienne. Ręczny reset klucza a secedit = to są tu dwie niezależne sprawy przeze mnie podnoszone. SubInACL się nie aplikuje z biegu, dlatego nawet o tym nie pisałam.



.

#7 Orlin

Orlin

    First Rank

  • Użytkownicy
  • 30 postów
  • Płeć:Mężczyzna
  • Lokalizacja:PL

Napisano 07 07 2009 - 23:52

Po przejęciu klucza na własność kasowanie idzie OK - mam tylko jeszcze jedno pytanie - co w przypadku np. klucza:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~0.0.0.0, w którym oprócz wartości zawierającej wyszukiwany ciąg (KB........) są jeszcze inne wartości z innymi KB.......? Kasuje wtedy tylko te wartości z poszukiwanym KB........ czy cały klucz? A jeśli tylko wybrane, to czy przywracać poprzedniego właściciela (SYSTEM) po usunięciu, tego co było do usunięcia?

M.

PS: Najpierw spróbowałem sposób z RegASSASSIN, potem z psexec i oba nie zadziałały - dopiero sposób z przejmowaniem na własność.

#8 Gość_picasso_*

Gość_picasso_*
  • Goście

Napisano 07 07 2009 - 23:57

PS: Najpierw spróbowałem sposób z RegASSASSIN, potem z psexec i oba nie zadziałały - dopiero sposób z przejmowaniem na własność.


Widać z mojej wypowiedzi, iż chodzi mi o proces ręczny, bo rozpisałam to właśnie wg kolejności kroków ręcznych. A Psexec ma mniejsze zastosowanie pod Vista w tych kontekstach, gdyż konto SYSTEM jest podobnie upośledzone w stosunku do pewnych kluczy jak Administratorzy. To konto TrustedInstaller pełni rolę "bossa". Mimo iż są klucze gdzie Właścicielem jest SYSTEM, to i tak dostęp jest skonfigurowany w węższym zakresie wymagając rekonfiguracji. Oczywiście rzecz jeszcze zależy konkretnie od danego klucza - ale to widać oglądając uprawnienia w ręczny sposób.

co w przypadku np. klucza:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Component Based Servicing\PackageDetect\Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~0.0.0.0, w którym oprócz wartości zawierającej wyszukiwany ciąg (KB........) są jeszcze inne wartości z innymi KB.......? Kasuje wtedy tylko te wartości z poszukiwanym KB........ czy cały klucz? A jeśli tylko wybrane, to czy przywracać poprzedniego właściciela (SYSTEM) po usunięciu, tego co było do usunięcia?


Kasuj tylko wpisy odnoszące się do konkretnych KB..., nie ruszaj nadrzędnego klucza, który zbiera więcej niż jeden zapis, relatywny do innej łaty. Tak - Dla takich kluczy uprawnienia resetujesz tylko tymczasowo, by móc skasować wartość ze środka, w ich przypadku należy po wykonaniu akcji przywrócić domyślny układ zabezpieczeń widziany przed kasacją, powtarzając kroki odwrotnie tzn. rekonstruując pierwszego Właściciela i odbierając uprawnienia tym kontom, które go nie miały uprzednio. Zanotuj sobie przed przyznawaniem uprawnień jak to wygląda przed, byś mógł się tym posłużyć. W razie wątpliwości porówna się z moim kluczykiem, bo nigdy tych obszarów ręcznie nie modyfikowałam, więc można założyć, że są to ustawienia systemowe i nienaruszone.

Jeśli Właścicielem takiego nadrzędnego klucza jest SYSTEM, to można sobie uprościć zmniejszając liczbę operacji o modyfikowanie Właściciela - zastartować regedit jako SYSTEM przez psexec, dodać tymczasową Pełną kontrolę dla konta SYSTEM, usunąć wpis, odebrać Pełną kontrolę dla tego konta.



.

#9 Orlin

Orlin

    First Rank

  • Użytkownicy
  • 30 postów
  • Płeć:Mężczyzna
  • Lokalizacja:PL

Napisano 08 07 2009 - 00:23

Inne metody niż na początku napisałaś przetestowałem - bo wtedy jeszcze wyglądało dla mnie, że robią prawie to samo przy mniejszym nakładzie pracy - a wspomniałem o tym, bo miałem cichą nadzieję, że właśnie wytłumaczysz dlaczego nie zadziałały i poszerzysz tym samym ciut moją wiedzę - za co dziękuję :-)
Jeśli chodzi o kasowanie wpisów - to nawet się domyślałem, że właśnie tak trzeba robić włącznie z tymczasowym przejmowaniem kluczy, ale wolałem się upewnić. Tylko nie myślałem, że jeszcze odpowiesz i już wyłączyłem notebooka - ale w takim razie wracam do kasowania.

Kolorowych snów - o wynikach operacji dam znać już jutro, tj dziś, ale za dnia.

M.

#10 Orlin

Orlin

    First Rank

  • Użytkownicy
  • 30 postów
  • Płeć:Mężczyzna
  • Lokalizacja:PL

Napisano 08 07 2009 - 02:00

Może jeszcze nie dzień, ale piszę co i jak...
Niestety - po wykasowaniu z danej gałęzi wszystkich wartości i kluczy zawierających w nazwie jedno z czterech problematycznych KB....... nadal aktualizacje się nie chcą zainstalować (ten sam błąd 80070490).
Kasowania było od groma (na pewno ponad 100 wartości i kluczy) i moją jedyną pomyłką było to, że pozostawiłem przy jednym z kluczy uprawnienia do pełnej kontroli dla Systemu (zamiast samego odczytu). A no właśnie - skorzystałem od razu z Twojego wyjaśnienia - i by zaoszczędzić trochę klikania użyłem psexeca - i tylko poszerzałem (a następnie przywracałem) uprawnienia SYSTEMu. Jakbym miał przejmować na własność, to jeszcze z godzinę bym nad tym siedział.

Jakieś dalsze sugestie? :-)

M.

#11 Gość_picasso_*

Gość_picasso_*
  • Goście

Napisano 08 07 2009 - 02:28

nadal aktualizacje się nie chcą zainstalować (ten sam błąd 80070490)


Czy one zwracają taki sam błąd po pobraniu ręcznym na dysk i próbie uruchomienia (nie z Windows Update)? Czy Narzędzie analizy gotowości nadal zwraca, że jest "niekompatybilne" z tym systemem? Czy już teraz po secedit, które robiłeś z FixIt, odnowienie instalacji Windows Update Agent + restart również nie ma skutków?

1. Spróbowałabym jeszcze zainteresować się katalogiem C:\WINDOWS\Servicing\Packages:

----> Może jakiś plików *.mum / *.cat po prostu tam brakuje i wymagane jest ich uzupełnienie. Narzędzie analizy gotowości nie działa, to i nie można tego zweryfikować w sposób wygodny, a jedynie sugerować się na podstawie CBS.LOG. Sprawa też i tego typu, że 4 łaty to trochę "dużo", i się zastanawiam czy przypadkiem niemożność ich instalacji nie pochodzi z innego braku. Z drugiej strony to ja widziałam dużo logów z checksur, gdzie braków w packages to była cała kolekcja. Spróbujmy. Pobrałam ręcznie te łaty w wersji x64 PL, rozwaliłam pakiety *.msu, tutaj cała paczka oryginalnych plików ze środka łat: KLIK. Zachowałam całość jak powstało po rozbiciu wewnętrznego cab, na wszelki wypadek jakby tu nie był widoczny cały CBS.log, mimo iż na uwadze mam podstawienie tylko fragmentów = odniosłabym się do tego co gadał CBS.LOG, tu są nazwy dla plików mum / cat:

2009-07-07 20:05:03, Error				 CBS	Failed to resolve Package: Package_for_KB968537_winpesrv~31bf3856ad364e35~amd64~~6.0.1.2. hr: 0x80070490
2009-07-07 20:05:03, Error				 CBS	Failed to resolve child of Package: Package_for_KB968537~31bf3856ad364e35~amd64~~6.0.1.2. hr: 0x80070490

2009-07-07 20:05:46, Error				 CBS	Failed to resolve Package: Package_for_KB967632_server~31bf3856ad364e35~amd64~~6.0.1.2. hr: 0x80070490
2009-07-07 20:05:46, Error				 CBS	Failed to resolve child of Package: Package_for_KB967632~31bf3856ad364e35~amd64~~6.0.1.2. hr: 0x80070490

2009-07-07 20:06:00, Error				 CBS	Failed to resolve Package: Package_for_KB970238_winpesrv~31bf3856ad364e35~amd64~~6.0.1.0. hr: 0x80070490
2009-07-07 20:06:00, Error				 CBS	Failed to resolve child of Package: Package_for_KB970238~31bf3856ad364e35~amd64~~6.0.1.0. hr: 0x80070490

2009-07-07 20:06:18, Error				 CBS	Failed to resolve Package: Package_for_KB961501_server~31bf3856ad364e35~amd64~~6.0.1.1. hr: 0x80070490
2009-07-07 20:06:18, Error				 CBS	Failed to resolve child of Package: Package_for_KB961501~31bf3856ad364e35~amd64~~6.0.1.1. hr: 0x80070490

Wstaw do C:\WINDOWS\Servicing\Packages wyłuskane z mojej paczki pliki zgodne z nazwami podanymi przez CBS.LOG (sprawdź jeszcze co mówi aktualnie CBS.LOG po tej kasacji w rejestrze), w postaci sparowanej mum + cat. I ponów instalację łatek.

----> Mając na uwadze potencjalne uszkodzenie, może postąpić odwrotnie, tzn. jeśli takie pliki już tam są, skosić je (w dalszej kolejności zamienić na nowe z mojej paczki). Przed kasacją zrób ich backup ręcznie w jakimś miejscu, następnie wykonaj przyznawanie uprawnień na nich (tu jedzie podobnie jak w rejestrze: przejęcie na Własność + Pełna kontrola) + kasacja.

----> Zweryfikuj ponadto uprawnienia do tego katalogu + kolegi C:\WINDOWS\WinSxS. Uprawnienia powinny być następujące: TrustedInstaller jako Właściciel, dla "Ten folder, podfoldery i pliki" Pełna kontrola dla TrustedInstaller, za to konta SYSTEM + Administratorzy + Użytkownicy mają tylko Odczyt + wykonywanie.

I pokaż nowy CBS.LOG, tylko fragment narosły aktualnie. Mógłbyś też przeprowadzić sfc /verifyonly - i przefiltrować CBS.LOG na wyniki z błędami, o ile takowe byłyby wykryte.


2. No cóż, poszukałam jeszcze w MS, i oni też krążą w podobnych obszarach, bo twierdzą (KB958044), że jest uszkodzenie w manifestach, tylko że mają jedną nieciekawą propozycję = nakładkowa Reperacja z DVD... W takiej sytuacji spróbowałabym jeszcze Przywracania systemu, o ile cień nie nosi wady już w tym punkcie:

Nie próbowałem jeszcze odinstalowywania SP2, ani przywracania systemu (do stanu sprzed 7 dni, kiedy się zainstalował SP2)






.

#12 Flavius

Flavius

    Expert Rank

  • Na emeryturze
  • 3769 postów
  • Płeć:Mężczyzna

Napisano 08 07 2009 - 07:12

----> Może jakiś plików *.mum / *.cat po prostu tam brakuje i wymagane jest ich uzupełnienie. Narzędzie analizy gotowości nie działa, to i nie można tego zweryfikować w sposób wygodny, a jedynie sugerować się na podstawie CBS.LOG. Sprawa też i tego typu, że 4 łaty to trochę "dużo", i się zastanawiam czy przypadkiem niemożność ich instalacji nie pochodzi z innego braku. Z drugiej strony to ja widziałam dużo logów z checksur, gdzie braków w packages to była cała kolekcja. (...)Wstaw do C:\WINDOWS\Servicing\Packages wyłuskane z mojej paczki pliki zgodne z nazwami podanymi przez CBS.LOG

Dając komuś taką poradę świadczy to tylko o twojej bucie i utraty poczucia realnej rzeczywistości myśląć i wmawiając wszystkim że wiesz od wszystkich na świecie więcej i umiesz w pełni kontrolować proces aktualizacji systemu -nikt na świecie tego na 100% nie potrafi i ty także nie....nawet MS tego nie potrafi.Ja nawet śmiem wątpić czy rzeczywiście te pakiety są uszkodzone mimo komunikatu narzędzia - przecież jeszcze niedawno wszystko dobrze działało

Co do samego błędu...to tak naprawdę brak rozwiązania jeśli Redirness Tool nie pomógł...
to powszechnie znane są dwa:przywracanie systemu i reparacja....choć oczywiście w sieci są też i inne mętne sygnały o rzekomych rozwiązaniach KLIK

Jest w tym linku np. informacja że komuś na ten przypadek pomogła deinstalcja DEAMON Tools ponoć głównym winowajcą miał być C:\Windows\System32\Drivers\sptd.sys
- możliwe że inne programy do wirtualizacji napędów czy nagrywania rzeczywiście powodują ten błąd.Odinstaluj takie rzeczy i jeszcze sprawdź ręcznie KLIK czy jakiej usługi sterownikowej z samym sterownikiem te programy nie zostawiły - to możesz sprawdzić.Możliwe też że w niektórych przypadkach jest to problem z uprawnieniami

Oczywiście to ty wybierzesz którą poradę wybrać - ale moja rada jest taka jak wszystko zawiedzie:przywróć system do chwili zaraz po instalacji SP2 lub dokonaj reparacji....w rzeźbę podmiany komponentów się nie baw bo to robota głupiego
Głos Opozycji Forumowej

#13 Gość_picasso_*

Gość_picasso_*
  • Goście

Napisano 08 07 2009 - 07:15

Dając komuś taką poradę świadczy to tylko o twojej bucie i utraty poczucia realnej rzeczywistości myśląć i wmawiając wszystkim że wiesz od wszystkich na świecie więcej i umiesz w pełni kontrolować proces aktualizacji systemu -nikt na świecie tego na 100% nie potrafi i ty także nie....nawet MS tego nie potrafi.Ja nawet śmiem wątpić czy rzeczywiście te pakiety są uszkodzone mimo komunikatu narzędzia - przecież jeszcze niedawno wszystko dobrze działało


Przykład rozwiązania pewnego problemu z kodem 0x80070490 w ten sposób: KLIK. Czyli nic nie traci próbując to wykonać, skoro w perspektywie i tak ma gromkie Przywracanie / Reperację.

#14 Orlin

Orlin

    First Rank

  • Użytkownicy
  • 30 postów
  • Płeć:Mężczyzna
  • Lokalizacja:PL

Napisano 08 07 2009 - 16:10

Ściągnąłem i zainstalowałem najpierw jedną poprawkę (KB961501) - i niby się poprawnie zainstalowała - ale po restarcie w WU nadal pokazywał te 4 (i dwie opcjonalne - Windows Live, Office Live - o których nie wspominałem, ale cały czas się pojawiają). Dla pewności doinstalowałem jeszcze trzy pozostałe (te nieopcjonalne) - kolejny restart - i o dziwo Windows Update pokazuje, że system jest aktualny - i te cztery problematyczne zakończone wreszcie powodzeniem. Teraz pytanie - czy czekać do wtorku na jakieś łatki, by sprawdzić, czy się przez WU zainstalują, czy zainstalować już teraz którąś opcjonalną?

Tylko się dziwię, czemu sam od tego nie zacząłem - nawet koledze to niedawno doradziłem - tylko odnośnie SP2, który nie chciał się zainstalować (aczkolwiek tam problem wg logów był z jakąś komendą w katalogu boot i w ogóle nie można było edytować ustawień windowsowego bootmanagera - ale pomogło ustawienie windowsowej partycji jako aktywnej - wtedy się zainstalowało i można było zmieniać ustawienia bootmanagera).

Pozdr.,
M.

#15 Gość_picasso_*

Gość_picasso_*
  • Goście

Napisano 08 07 2009 - 16:16

To znaczy które operacje użyłeś do używienia instalacji? Po prostu pobrałeś i z dysku instalacja?

Dla pewności doinstalowałem jeszcze trzy pozostałe (te nieopcjonalne) - kolejny restart - i o dziwo Windows Update pokazuje, że system jest aktualny - i te cztery problematyczne zakończone wreszcie powodzeniem. Teraz pytanie - czy czekać do wtorku na jakieś łatki, by sprawdzić, czy się przez WU zainstalują, czy zainstalować już teraz którąś opcjonalną?


Sprawdziłabym proces na jakieś opcjonalnej oraz czy teraz da się uruchomić Narzędzie analizy gotowości systemu.




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych