Skocz do zawartości


tablety.pl
Zdjęcie
- - - - -

Problem z net framework




  • Zamknięty Temat jest zamknięty
7 odpowiedzi w tym temacie

#1 Save

Save

    First Rank

  • Użytkownicy
  • 7 postów

Napisano 05 01 2012 - 22:10

Znowu mam problem z tym szajsem.
Kiedyś usunąłem wszystkie wersje, bo myślałem, że coś z nimi nie tak (jakieś błędy, które okazało się dotyczyły czegoś innego). Wcześniej miałem zainstalowane wszystkie wersje do 3.5

Przez około rok miałem zainstalowane wszystkie wersje do 2.0

Teraz chce mieć wersje 3.5 bo nie działa mi gra. Czytałem, że najpierw trzeba usunąć je programem: dotnetfx_cleanup_tool_ więc tak zrobiłem

Wersje 1.1 zainstalowałem bez problemu
Ale gdy instaluje wersje 2.0 mam błąd:
Dołączona grafika

A gdy omijam tą wersje, i instaluje inne to mam błąd krytyczny.

Zrobiłem takie czynności jak

1. Przejdź do: C:\Windows\WinSxS\Policies

Odszukaj tam folder x86_policy.8.0.Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_x-ww_77c24773 (lub podobnej nazwy).

Zrób jego kopię (np. na Pulpit) i skasuj oryginał. Jeżeli nie pomoże, zrób kopię całego folderu Policies i skasuj oryginał.

2. Przejdź do C:\Windows\system32 i odszukaj tam bibliotekę (o ile będzie) mscoree.dll. Zrób jej kopię i skasuj oryginał.

3. Przejdź do Rejestru i w kluczu: HKLM\SOFTWARE\Microsoft\.NETFramework\policy\v2.0
Jeśli taki klucz istnieje, zrób jego kopię a oryginał skasuj.

4. Masz problem z plikiem advpack.dll (tak wynika ze screena) a jest on niezbędny przy instalacji oprogramowania (m.in. weryfikuje pliki inf, czyli pliki instalacyjne). Sugeruje podmienić go via Konsola Odzyskiwania według podanych tam schematów.

Jeżeli dalej będą występować kłopoty, proszę uściślić jakie. Poza tym zakładam, że prawidłowo odinstalowałeś poprzednie wersje (o ile takowe były) i dokładnie przeczyściłeś system.

Próby należy dokonywać pojedyńczo!


I to nic nie dało

Proszę o pomoc

#2 XanTyp

XanTyp

    Expert Rank

  • Admins
  • 3887 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Headquarter

Napisano 05 01 2012 - 22:48

Teraz chce mieć wersje 3.5 (...) Wersje 1.1 zainstalowałem bez problemu
Ale gdy instaluje wersje 2.0 mam błąd

A po co się bawisz w te podchody z kolejnymi wersjami? Usuń starsze i zainstaluj wprost 3.5
Przecież to suma wszystkich poprzedniczek plus uaktualnienia.

Nawet, jeśli nie będę mógł pomóc, to może coś podpowiem:

1. Najpierw sięgnij do źródła, potem dopiero dzwoń po hydraulika.

2. Precyzja odpowiedzi zależy przed wszystkim od precyzji zadanego pytania.
3. Nie czytam w myślach, ale mogę powróżyć na specjalne życzenie (:


#3 Save

Save

    First Rank

  • Użytkownicy
  • 7 postów

Napisano 06 01 2012 - 12:14

Teraz chce mieć wersje 3.5 (...) Wersje 1.1 zainstalowałem bez problemu
Ale gdy instaluje wersje 2.0 mam błąd

A po co się bawisz w te podchody z kolejnymi wersjami? Usuń starsze i zainstaluj wprost 3.5
Przecież to suma wszystkich poprzedniczek plus uaktualnienia.



A dlaczego 3.5 a nie 4.0
I tak mam błąd krytyczny gdy to instaluję..

#4 XanTyp

XanTyp

    Expert Rank

  • Admins
  • 3887 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Headquarter

Napisano 06 01 2012 - 14:39

A dlaczego 3.5 a nie 4.0

Skoro chcesz 3.5, to instaluj 3.5 vide pierwszy post:

Teraz chce mieć wersje 3.5

I tak mam błąd krytyczny

A tym błędem jest? Treść, screen, cokolwiek? Bo pierwszy screen nie przypomina mi żadnego błędu krytycznego, jeśli o tym konkretnym myślisz.

Przy okazji, póki co, rozmawiamy tutaj sami więc nie musisz cytować całych postów, żeby dalej coś dopisać. Zrozumiem ciąg logiczny wywodu z wybranym fragmentem lub bez niego.

Nawet, jeśli nie będę mógł pomóc, to może coś podpowiem:

1. Najpierw sięgnij do źródła, potem dopiero dzwoń po hydraulika.

2. Precyzja odpowiedzi zależy przed wszystkim od precyzji zadanego pytania.
3. Nie czytam w myślach, ale mogę powróżyć na specjalne życzenie (:


#5 Save

Save

    First Rank

  • Użytkownicy
  • 7 postów

Napisano 06 01 2012 - 15:41

Podczas instalacji 4.0
Dołączona grafika

Podczas instalacji 3.5 jest praktycznie to samo

#6 XanTyp

XanTyp

    Expert Rank

  • Admins
  • 3887 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Headquarter

Napisano 06 01 2012 - 21:50

Dla wszelkiej pewności, spróbuj raz jeszcze, ale w trybie awaryjnym.

Nawet, jeśli nie będę mógł pomóc, to może coś podpowiem:

1. Najpierw sięgnij do źródła, potem dopiero dzwoń po hydraulika.

2. Precyzja odpowiedzi zależy przed wszystkim od precyzji zadanego pytania.
3. Nie czytam w myślach, ale mogę powróżyć na specjalne życzenie (:


#7 Save

Save

    First Rank

  • Użytkownicy
  • 7 postów

Napisano 07 01 2012 - 15:18

To samo.
Zrobiłem to co mi radzili na innym forum.
1.Pobrałem i zainstalowałem sp.3
2.Przez windows update pościagałem poprawki krytyczne

Ale:
Tych aktualizacji mi nie instaluje:

Aktualizacja zabezpieczeń dla programu Microsoft .NET Framework 1.1 z dodatkiem SP1 w systemach Windows XP, Windows Vista i Windows Server 2008 x86 (KB2572067)
A GDY POBIERAM NA DYSK TĄ AKTUALIZACJĘ I WŁĄCZAM TO PO WYODRĘBNIANIU MAM TAKI BŁĄD:
Dołączona grafika



Aktualizacja zabezpieczeń dla programu Microsoft XML Core Services 4.0 z dodatkiem Service Pack 2 (KB954430)

Aktualizacja zabezpieczeń dla programów Microsoft .NET Framework 3.5 z dodatkiem SP1 i 2.0 z dodatkiem SP2 w systemach Windows 2000, Windows Server 2003 i Windows XP x86 (KB979909)

Aktualizacja dla programów Microsoft .NET Framework 3.5 z dodatkiem SP1 i 2.0 z dodatkiem SP2 w systemach Windows Server 2003 i Windows XP x86 (KB982167)

Aktualizacja zabezpieczeń dla programu Microsoft .NET Framework 2.0 z dodatkiem SP2 i 3.5 z dodatkiem SP1 w systemach Windows Server 2003 i Windows XP x86 (KB2418241)

Aktualizacja dla programów Microsoft .NET Framework 3.5 z dodatkiem SP1 i 2.0 z dodatkiem SP2 w systemach Windows Server 2003 i Windows XP x86 (KB982524)
Internet Explorer 8 dla systemu Windows XP

Aktualizacja zabezpieczeń dla programu Microsoft .NET Framework 2.0 z dodatkiem SP2 w systemach Windows Server 2003 i Windows XP x86 (KB2572073)

Aktualizacja zabezpieczeń dla programu Microsoft .NET Framework 2.0 z dodatkiem SP2 w systemach Windows Server 2003 i Windows XP x86 (KB2539631)

Aktualizacja zabezpieczeń dla programu .NET Framework 2.0 z dodatkiem SP2 i 3.5 z dodatkiem SP1 w systemach Windows Server 2003 i Windows XP x86 (KB2518864)

A GDY TE 7 AKTUALIZACJI POBIERAM NA DYSK I WŁĄCZAM TO PO WYODRĘBNIENIU MAM TAKI BŁĄD:
Dołączona grafika



#8 Groszexxx

Groszexxx

    Medium Rank

  • Użytkownicy +
  • 363 postów

Napisano 07 01 2012 - 20:24

Powiedz mi tak - Twój windows nie jest tweakowany, modyfikowany? Jakas samorobka czy kopia zapasowa oryginału? Pytam, bo to może być ważny krok.
Druga sprawa - sciagnij może Revounistaller - zobacz czy nie zostały jakieś resztki po standardowej dezinstalacji tego frameworka - usuń je w razie konieczności - wszystko dosłownie. Zrób przed tym backup oczywiscie. Potem zobacz czy proces instalacji pójdzie.
Gdyby i to nie pomogło to zastosujemy troszke pracochlonna metode polegajaca na tym, ze sciagniesz jakis obraz xp, w razie czego Ci podam, ktory i postawisz wirtualna maszyne. Zobaczymy czy na takim swiezym xp pojdzie instalka frameworka.
Tyle ode mnie poki co.




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych