Skocz do zawartości


tablety.pl
Zdjęcie

Błędy CRC w plikach na dysku zewnętrznym




  • Zaloguj się, aby dodać odpowiedź
10 odpowiedzi w tym temacie

#1 dzięcioł

dzięcioł

    First Rank

  • Użytkownicy
  • 72 postów

Napisano 06 02 2012 - 17:54

Część z plików które zapisywałem na dysku Seagate FreeAgent ST305004FDD1E1-RK nie nadaje się do użytku z powodu błędów CRC. Najbardziej cierpią instalki i archiwa. Podczas instalacji wyskakują błędy CRC, a archiwa wypakowują się do pewnego momentu, po czym wyskakuje błąd mówiący o uszkodzonym archiwum. Znalazłem informację, że Firmware niektórych dysków Seagate był uszkodzony. Sprawdziłem moją wersję Firmware i okazało się że mam najnowszą, więc ten trop raczej odpada. Zrobiłem skanowanie programem Victoria i proszę o interpretację raportu oraz ewentualnie dalsze rady.

Oto raport:
http://www.wklejto.pl/116562

Wklej.org nie działa, ale jak widać, da się jeszcze wcisnąć raporty gdzie indziej.

Bardzo sorry. Mój błąd.

Użytkownik dzięcioł edytował ten post 06 02 2012 - 20:42


#2 Pentium320

Pentium320

    Very Good Rank

  • Moderatorzy
  • 1019 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Rumia (Trójmiasto)

Napisano 07 02 2012 - 01:32

Skoro to dysk zewnętrzny to zasadnicze pytanie, czy dzieje się to na każdym komputerze? Bo to nie koniecznie musi być wina dysku.
Poprosiłbym screen z programu Victoria - zakładka SMART (w razie problemów, a Victoria takowe niestety miewa zwłaszcza na 64-bit można użyć CrystalDiskInfo lub trialowej wersji HDTune Pro, który nie powinien mieć problemu z odczytaniem SMART)

#3 dzięcioł

dzięcioł

    First Rank

  • Użytkownicy
  • 72 postów

Napisano 07 02 2012 - 14:05

Screen z Cristala

Dysk na innych komputerach zachowywał się jeszcze dziwniej. Nie pamiętam już błędów które wtedy pokazywał bo było to dłuższy czas wstecz. Kurczę nie mam teraz możliwośći sprawdzić go na innym komputerze. Za kilka dni powinien do mnie wrócić z reklamacji laptop i wtedy sprawdzę go na lapku.

Chyba można wykluczyć wstępnie winę uszkodzonego "fabrycznie" firmware'u.

#4 Pentium320

Pentium320

    Very Good Rank

  • Moderatorzy
  • 1019 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Rumia (Trójmiasto)

Napisano 07 02 2012 - 15:50

Z dyskiem wygląda wszystko raczej dobrze...

Mówisz, że dysk zachowywał się jeszcze dziwniej na innych komputerach, czym to się objawiało?

Oczywiście banalne rozwiązanie jak wymiana kabla USB (o ile jest taka opcja) próbowałeś?

Póki nie masz możliwości sprawdzenia go na innym komputerze to proponuję sprawdzić pamięć ram programem Memtest86+ (koniecznie wersja bootowalna), nagrywasz na płytę CD i uruchamiasz z niej komputer i testujesz pamięć, i ma nie być żadnych błędów. Często pamięć ram powoduje właśnie takie błędy jak opisane wyżej, czyli błąd danych CRC przy wypakowywaniu itp.

#5 Groszexxx

Groszexxx

    Medium Rank

  • Użytkownicy +
  • 363 postów

Napisano 07 02 2012 - 16:15

testowanie pamieci ram z uruchomionego systemu - to tak samo jak usuwanie wirusow z zainfekowanego systemu - daje niewiarygodne wyniki, wiec nie podawaj rad, zeby odpalil memtesta z wersji niebootowalnej.
Skoro dysk mial problemy przy pracy z innym sprzetem to moim zdaniem nie jest to kwestia ramu.
Ja bym polecil sprawdzic jak sie dysk zachowuje na jakims linuksie, a to mozna sprawdzic w wygodny sposob na wirtualnej maszynie.

...albo pod miniXP, który często doradzasz ;)

Użytkownik XanTyp edytował ten post 07 02 2012 - 16:45


#6 dzięcioł

dzięcioł

    First Rank

  • Użytkownicy
  • 72 postów

Napisano 07 02 2012 - 17:19

Mówisz, że dysk zachowywał się jeszcze dziwniej na innych komputerach, czym to się objawiało?


Już nie pamiętam dokładnie. Przy kopiowaniu danych na komputer były jakieś błędy, ale nie pamiętam jakie. Wspomniałem o tym tylko orientacyjnie.

Z przewodem USB spróbuję. Szczerze... to nawet o tym nie pomyślałem.

Pamięć ram jest raczej ok. Niedawno wymieniałem ją na 4GB, ale problem z dyskiem trwa od dłuższego czasu, więc winę ramu raczej można wykluczyć.

Ja bym polecil sprawdzic jak sie dysk zachowuje na jakims linuksie, a to mozna sprawdzic w wygodny sposob na wirtualnej maszynie.

Zaraz zainstaluję Ubuntu na Virtualboxie.


I mały offtop. Jeśli chdzi o memtesta bootowalnego... przy skanowaniu, jeden cykl trwa około pół godziny i test leci na nowo bez wyraźnego zakończenia. Czy należy czekać na wyraźne zakończenie programu, czy też skanowanie może się powtarzać w kółko bez końca?

#7 Pentium320

Pentium320

    Very Good Rank

  • Moderatorzy
  • 1019 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Rumia (Trójmiasto)

Napisano 07 02 2012 - 20:07

testowanie pamieci ram z uruchomionego systemu - to tak samo jak usuwanie wirusow z zainfekowanego systemu - daje niewiarygodne wyniki, wiec nie podawaj rad, zeby odpalil memtesta z wersji niebootowalnej.

proponuję sprawdzić pamięć ram programem Memtest86+ (koniecznie wersja bootowalna), nagrywasz na płytę CD (...)

Gdzie podałem taką poradę?

I mały offtop. Jeśli chdzi o memtesta bootowalnego... przy skanowaniu, jeden cykl trwa około pół godziny i test leci na nowo bez wyraźnego zakończenia. Czy należy czekać na wyraźne zakończenie programu, czy też skanowanie może się powtarzać w kółko bez końca?

Wystarczy jedna lub 2 pętle, test nigdy się nie kończy i będzie chodził "w kółko" dopóki nie wyłączysz


Skoro dysk mial problemy przy pracy z innym sprzetem to moim zdaniem nie jest to kwestia ramu.

Aczkolwiek autor nie był pewny, więc nie zaszkodzi. Rozwiązanie z Linuxem również nie zaszkodzi ;)

#8 dzięcioł

dzięcioł

    First Rank

  • Użytkownicy
  • 72 postów

Napisano 08 02 2012 - 00:33

Instalator napotkał nienaprawialny błąd. Uruchomiona zostanie sesja mająca na celu zdiagnozowanie błędu i powtórzenie instalacji... Daaaaaj kamienia!!!

#9 Groszexxx

Groszexxx

    Medium Rank

  • Użytkownicy +
  • 363 postów

Napisano 08 02 2012 - 22:28

Zrob na tym dysku zerowanie czy tam formatowanie niskopoziomowe, o ile nie ma badow fizycznych

#10 dzięcioł

dzięcioł

    First Rank

  • Użytkownicy
  • 72 postów

Napisano 13 05 2012 - 12:45

Sorry za długą nieobecność w tym temacie. Nie chcę robić formatowania, bo mam na tym dysku sporo innych danych które da się normalnie odczytać. Teraz dysk jest podłączony do routera, jako dysk sieciowy poprzez usb i wszystko działa w miarę dobrze. Nie ma błędów crc, ale potestuję go jeszcze. Jeśli to nie sprawi kłopotu, prosze o niezamykanie tematu. W razie gdyby okazało się że problem nie ustąpił, dobrze byłoby pisać dalej w tym samym temacie.

#11 dzięcioł

dzięcioł

    First Rank

  • Użytkownicy
  • 72 postów

Napisano 25 06 2013 - 20:42

Ok. Skopiowałem dane które były mi potrzebne. Mogę robić formatowanie na tym dysku. Jeśli chodzi o formatowanie niskopoziomowe, zajrzałem do Google i trafiłem na różne opinie. Jakiś user napisał że format niskopoziomowy może uszkodzić dysk. Ile w tym prawdy? Jak tego dokonać? Czy naprawdę warto?

 

Wydaje mi się że wina leży po stronie przewodu usb. Po wymianie nie spotkałem się z błędem CRC, jednak niezbyt wiele danych nim kopiowałem. Chcę ten dysk sformatować do formatu ext4 i podłączyć pod router. Domyślam się że nie jest to formatowanie niskopoziomowe. Wspominam o tym by pokazać że nie zalezy mi na danych zawartych na dysku, ponieważ mam ich kopię na nowym dysku.

 

Proszę o pomoc w doprowadzeniu sprawy do końca.






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych