Skocz do zawartości


tablety.pl
- - - - -

Nicotine




  • Zamknięty Temat jest zamknięty
23 odpowiedzi w tym temacie

#1 Gość_nierymek_*

Gość_nierymek_*
  • Goście

Napisano 17 11 2003 - 00:27

00:25:13 Can not log in, reason: INVALIDVERSION

Oto komunikat, który dostałem na Nikotynce. Czy jakieś zmiany zostały poczynione na serwerze?
Orientuje się ktoś o co chodzi?

#2 Gość_picasso_*

Gość_picasso_*
  • Goście

Napisano 18 11 2003 - 07:56

Został osiągnięty limit X userów w tym samym czasie i Cię wyrzuciło. W tym przypadku w Soulseeku dla Windowsa pojawia się komunikat "This server is private", a w Soulseeku dla Linuxa "Invalid version" mylnie sugerując związki z numerem wersji.

Co zrobić? Tylko cierpliwość.....

#3 szamrok

szamrok

    Expert Rank

  • Użytkownicy +
  • 1965 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Kraków

Napisano 08 03 2004 - 16:24

Natrafilem na takie oto problemy przy uruchamianiu nicotine (jesli ktos bedzie takie mial, to rozwiaznie ponizej)
jesli pomimo tego ze mamy zainstalowanego pythona oraz pyGTK a program nadal twierdzi ze nie mamy pyGTK, nalezy sprawdzic czy pyGTK zainstalowalo sie w /usr/lib/python2.3/site-packages/gtk-2.0
(zamiast python2.3 moze byc 2.2 zaleznie od tego ktora wersje posiadamy)
niektore paczki z pyGTK instaluja sie do /usr/local/lib zamiast /usr/lib, aby poprawic to nalezy skopiowac pliki z /usr/local/lib/python2.3/site-packages do /usr/lib/python2.3/site-packages
ewentualnie zsymlinkowac katalogi.
Kolejna sprawa to blad z pango i biblioteka libgtk-x11-2.0, spowodowany jest on gdy mamy zainstalowana wersje pango dla nowszego GTK (u mnie bylo to niezle zamieszane). Najprosciej bedzie to sprawdzic wchodzac tutaj ftp://ftp.gtk.org/pub/gtk/v2.2/
i sprawdzajac jakie sa wersje pango np: LATEST-PANGO-1.2.5, oznacza ze do gtk 2.2 trzeba miec pango-1.2.5 (ja mialem rozwojoweg GTK-2.3.6 i pango 1.5.5 i wszystko sie krzaczylo :D). Przeinstalowanie bibliotek rozwiazuje problem.
Osobiscie nie uzywalem zbyt czesto zadnego klienta SoulSeek jednak nicotine wywarl na mnie dobre wrazenie, duza ilosc opcji, przejrzyste menu, wszystko zorganizowane w formie zakladek, laczy sie szybko, pliki wyszukuje calkiem dobrze tylko nieco obciaza system w czasie searcha. Ogolnie calkiem dobry klient polecam przetestowac.
Dołączona grafika - darmowy program do katalogowania książek

#4 CKUreprezent

CKUreprezent

    Expert Rank

  • Na emeryturze
  • 3314 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Koshaolin

Napisano 17 10 2004 - 22:16

1.czy istnieje mozliwosc ustawienia ilosci slotow sciagania w w/w soulseeku?

2. chociaz mam ustawione ograniczenia transferu uploadu na 7 to ludzie mimo to moga sciagac powyzej 10Kb/s ... screen jak wyzej , cos jest zle ustawione ?

#5 szamrok

szamrok

    Expert Rank

  • Użytkownicy +
  • 1965 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Kraków

Napisano 18 10 2004 - 20:30

Jesli limit w Nicotine nawala to mozesz uzyc Trickle.

Odpowiedz odnosnie slotow tutaj.
Dołączona grafika - darmowy program do katalogowania książek

#6 CKUreprezent

CKUreprezent

    Expert Rank

  • Na emeryturze
  • 3314 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Koshaolin

Napisano 19 10 2004 - 17:41

calkowity bezsens....brak opcji samodzielnego wyboru ilosci slotow sciagania
w tym linku sie zakradl chyba blad albo zle zrozumialem a mianowicie opcja ustawiania slotow upload, da sie je ustawic na "sztywno"

nic mi to nie pomoglo ale dzieki

#7 szamrok

szamrok

    Expert Rank

  • Użytkownicy +
  • 1965 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Kraków

Napisano 19 10 2004 - 18:31

Watpie aby to byl blad, bo jest to oficjalny faq.
A czy brak slotow jest bezsensem to nie sadze, w faqu jest opisany powod takiego wyboru zarzadzania slotami.
Dołączona grafika - darmowy program do katalogowania książek

#8 Gość_c123457_*

Gość_c123457_*
  • Goście

Napisano 21 01 2005 - 15:56

Po zastosowaniu uwag "szamrok-a" nicotine zadziałało (Slackware 10).
Jedna uwaga dla uzytkowników - nie należy kasować plików w trakcie ściagania. Przypadkowo wykasowałem jeden.Okazało się, że nie jest on tak jak w SoulSeek-u zabezpieczony przed przypadkowym usunięciem(przynajmniej jeśli chodzi o partycje nielinuksowe, w tym wypadku FAT32). Najlepiej w trakcie konfiguracji ustawić osobny folder dla plików ściąganych i ściągniętych.
Moimo to program łatwy w konfiguracji dla kogoś kto miał do czynienia z SoulSeek czy innym p2p a o niebo bardziej stabilniejszy (ze zględu na platformę), dużo więcej opcji.

{na boku - Jakie ździwienie budzi fakt, że na czacie można pozdrowić kogoś nieznajomego i spytać jak pogoda w jego mieście... :huh:}
Nie polecam natomiast uruchamiania SoulSeek pod wine-em. Instalacja bez problemu natomiast działanie... Szkoda gadać. Prościej uzaleznić się od nicotine.

#9 zolw

zolw

    First Rank

  • Na emeryturze
  • 8 postów

Napisano 18 03 2005 - 10:29

mam taki problem chce zainstalowac soulseeka pod linuksem i musze zainstalowac nastepujęce pakiety:

1.Python >=2.2
2.wxPython >=2.4.1 (porty dla Gtk)
3.Gtk+ 1.2


punkt pierwszy zainstalowal sie bez problemu zorobilem to tak


tar -zxf Python-2.4.tgz

dalej

cd Python-2.4

./configure
a następnie
make && make install

jak pisalem instalacja przebiegla pomyslnie nie wyskoczyly zadne problemy ze brakuje jakis bibliotek itp

Teraz zabieram sie za Gtk+ 1.2 ktory instaluje w analogiczny sposob jednak pod koniec configuracji wywla mi cos takiego

GLIB 1.2.0 or better is required. The latest version of GLIB
*** is always available from ftp://ftp.gtk.org/.


ok wiec sciagam ten pakiet i instaluje dokladnie jak cala reszte niby wszytko ok ale gdy znow chce zainstalowac GTK 1.2 wywala mi komunikat ze chce tego GLIB 1.2.0 lub nowszy. zainstalowalem nowszy i problem ten sam lub

onfigure: error:
*** You must have either have gettext support in your C library, or use the
*** GNU gettext library. (http://www.gnu.org/s...xt/gettext.html


isciagam ten gettext instaluje sie bez problemu instaluje glib 1.2.0 i przy probie instalacji GTK 1.2 wywala mi cos takiego

configure: error:
*** GLIB 1.2.0 or better is required. The latest version of GLIB
*** is always available from ftp://ftp.gtk.org/.
[root@bartek-t1qgnks9 gtk+-1.2.0]#

bledene kolo bo przeciez juz zainstalowalem ten glib zarowno 1.2.0 a nawet sie pkusilem o 2.4.0 o co chodzi ?

ps pracuje na Mandrake 10.1 w KDE

#10 szamrok

szamrok

    Expert Rank

  • Użytkownicy +
  • 1965 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Kraków

Napisano 18 03 2005 - 18:22

W MDK trzeba doinstalowac chyba glib-devel. Glib w wersji 2.x a 1.2 to dwie rozne bajki, wiec instalacja 1.x nie pomoze, bo nicotine ma takie wymagania:

Nicotine has the following dependecies:

    * Python-2.2.0 or newer (Python 2.3 recommended due to improvements in the UTF-8 codec)
    * GTK+-2.0 or newer (GTK+-2.2 recommended)
    * PyGTK-1.99.16 or newer (older versions will NOT work)

Musisz miec gtk 2.x czyli gliba 2.x rowniez. GTK i gliba znajdziesz na plycie od mdk.
Dołączona grafika - darmowy program do katalogowania książek

#11 Gość_Guest_*

Gość_Guest_*
  • Goście

Napisano 17 05 2005 - 16:54

a ja mam taki problem:
proboje zainstalowac gtk+2.6.7 i zainstalowalem wszystkie potrzebne skladniki (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0) ale przy ./configure gtk+2.6.7 pokazuje sie:

checking for glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0... Package atk was not found in the pkg-config search path.
Perhaps you should add the directory containing `atk.pc'
to the PKG_CONFIG_PATH environment variable
No package 'atk' found

configure: error: Library requirements (glib-2.0 >= 2.6.0 atk >= 1.0.1 pango >= 1.8.0) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.


co jest nie tak??

#12 szamrok

szamrok

    Expert Rank

  • Użytkownicy +
  • 1965 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Kraków

Napisano 17 05 2005 - 18:20

Sprobuj w konsoli z prawami roota wpisac:
ln -s /usr/local/lib/pkgconfig/atk.pc /usr/lib/pkgconfig/atk.pc
W slacku to pomoze (na 99%), ale nie wiem jakie masz distro.
Jesli nie pomoze, to trzeba sprawdzic czy masz atka zainstalowanego np:
slocate -u
slocate atk

Dołączona grafika - darmowy program do katalogowania książek

#13 Gość_Guest_*

Gość_Guest_*
  • Goście

Napisano 09 06 2005 - 17:07

szukam po google czegos co mnie oswieci i trfilem na to forum. Instaluje ze zrodel epiphany, nie wiem czy to cos zmieni ale to z pkietow mi nie dziala.. i tak z nudow postanowilem sprobowac instalnoc to ze zrodel. Jednak po rozpakowaniu i wpisaniu komendy ./configure po pewnym czasie tej kompilacij czy jak to sie prawiodlowi nazywa pokazuje mi ten blad:
configure: error: Library requirements (                  glib-2.0 >= 2.4.1   pango >= 1.5.1              gtk+-2.0 >= 2.4.0               libxml-2.0 >= 2.6.6   libgnomeui-2.0 >= 2.6.0                   libglade-2.0 >= 2.3.1           bonobo-activation-2.0                   ORBit-2.0               libglade-2.0 >= 2.3.1   gnome-vfs-2.0 >= 2.3.1                  gnome-vfs-module-2.0            gconf-2.0              ) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them.
domyslam sie, ze brakuje mu tych pakietow... ale jakos nie moge sie ich doszukac i i tego nie jestem pewien czy to mi cos poomoze, moze tu o cos innego chodzi?

[ditr: Ubuntu]

#14 szamrok

szamrok

    Expert Rank

  • Użytkownicy +
  • 1965 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Kraków

Napisano 09 06 2005 - 17:24

Wiekszosc powyzszych pakietow powinna byc na plytce z ubuntu, no ale jesli ich nie znalazles to:
gtk, glib, pango -> www.gtk.org
bonobo,orbit,gnomve,gconf -> www.gnome.org
libglade -> http://www.jamesh.id...tware/libglade/
Dołączona grafika - darmowy program do katalogowania książek

#15 Easy_Rider

Easy_Rider

    First Rank

  • Na emeryturze
  • 2 postów

Napisano 30 06 2005 - 16:49

uzywam nicotine, od czoraj pokazuja mi sie takie komunikaty (sciezka i komentarz na koncu bywaja rozne):
przyklady:
-Peer message type 12547 size 33 contents '\x00\n\x00\x00\x00Trance Man\x8a:\x00\x00\n\x00\x00\x00Aphid Moon' unknown
-Peer message type 12547 size 40 contents '\x00\x07\x00\x00\x00Iainmac\x07\n\x00\x00\x14\x00\x00\x00autobots flesh eater' unknown

nie mam pojecia co to jest, na google'u nie znalazlem nic, brak mi idei.




Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych