Skocz do zawartości


tablety.pl
Zdjęcie
- - - - -

Brak dźwięków systemowych, na stronach internetowych, ...




  • Zamknięty Temat jest zamknięty
Brak odpowiedzi do tego tematu

#1 Placio74

Placio74

    Expert Rank

  • Użytkownicy +
  • 1833 postów
  • Płeć:Mężczyzna
  • Lokalizacja:Elbląg

Napisano 29 10 2006 - 21:38

I. Charakterystyczne objawy

1. Brak dźwięków przy odtwarzaniu klipów na serwisach YouTube, Google Video, ... - czyli brak dźwięku przy odtwarzaniu Flash Video.
Również brak dźwięku na stronach gdzie nie filmików, natomiast dźwięk (muzyka) odtwarzany jest z wykorzystaniem Flash'a - np. na stronce Maniacs of Noise. (Pomimo tego, że Flash Player jest zainstalowany.)

Jednak dźwięk jest obecny w klipach WMV np. na http://teledyski.onet.pl - jak również przy odtwarzaniu muzyki np. w Winamp'ie lub przy oglądaniu filmów.

1a. Poprawka odnośnie Winamp - jeśli Wyjście (Output) ustawione było na waveOut output i Mapowanie dźwięku Microsoft (co jak się zdaje jest domyślnym ustawieniem), występuje błąd:
Dołączona grafika

2. Brak ikonki Głośność w zasobiku systemowym (choć opcja Umieść ikonę głośności na pasku zadań jest włączona) .
Dołączona grafika

3. Brak dźwięków systemowych.

4. Brak dźwięku w niektórych programach, np. Gadu-Gadu.

5. Panel sterowania > Dźwięki i urządzenia audio > zakładka Dźwięki
Nieaktywna ikonka Odtwórz dźwięk.
Dołączona grafika

6. Panel sterowania > Dźwięki i urządzenia audio > zakładka Audio
Nie można ustawić urządzenia domyślnego w opcji Odtwarzanie muzyki MIDI.

Panel sterowania > Dźwięki i urządzenia audio > zakładka Głos
Nie można ustawić urządzenia domyślnego w opcji Odtwarzanie głosu.
Dołączona grafika Dołączona grafika

7. Panel sterowania > Dźwięki i urządzenia audio > zakładka Sprzęt
Brak widocznych kodeków w Kodery-dekodery wideo oraz Kodery-dekodery audio.
Możliwe, że będzie tylko widoczny Microsoft PCM Converter.
Dołączona grafika

8. W VirtualDub i podobnych programach korzystających z kodeków VfW (Video for Windows):
- pusta lista kodeków
Dołączona grafika Dołączona grafika
- przy próbie otworzenia pliku wideo, komunikat - Couldn't locate decompressor for format ...
Dołączona grafika


II. Możliwa i dość prawdopodobna przyczyna

Usunięty z rejestru (lub niekompletny) klucz: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32

Zaobserwowane po deinstalacji konkretnej wersji ffdshow z 2006-08-03 (kompilacja drevil_xxl'a) - możliwe również po zainstalowaniu (deinstalacji) niektórych paczek kodeków np. SLD Codeck Pack 1.5 (zdaża się też przy K-Lite).


III. Naprawa (5 opcji do wyboru)

1. Dodanie do rejestru brakujących wpisów.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32]
"midimapper"="midimap.dll"
"wavemapper"="msacm32.drv"
"aux"="wdmaud.drv"
"wdmaud.drv"="wdmaud.drv"
"wave"="wdmaud.drv"
"mixer"="wdmaud.drv"
"midi"="wdmaud.drv"

W systemowym Notatniku wklejamy powyższą zawartość
Dołączona grafika
potem w Notatniku - Plik > Zapisz jako
nadajemy plikowi nazwę i rozszerzenie .reg (zamiast .txt) - np. fix.reg
Dołączona grafika
następnie na zapisanym na dysku pliku po prostu klikamy dwa razy (importując zawartość do rejestru).

2. W K-Lite Codek Pack jest 'narzędzie' Codec Tweak Tool - opcja (Registry) Fix non-working system sound.
Działanie tej opcji ogranicza się do zaimportowania do rejestru wcześniej wymienionych wpisów.

About Codec Tweak Tool, [Registry] Fix Non-working system sound

3. Zastosowanie gotowego pliku .reg, tak jak w temacie - Nie słychać dźwięku na stronach WWW :/

4. Reinstalacja natywnych kodeków systemowych

5. Opcja naprawy systemu z płyty instalacyjnej systemu (poprawki systemowe jak i DirectX trzeba przeinstalować, także niesystemowe kodeki i filtry DirectShow).


IV. Uwagi

Powyższe rozwiązania (z wyjątkiem punktu 5) dotyczą tylko przypadku gdy w rejestrze został usunięty bądź jest niekompletny klucz:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32

Proszę wcześniej upewnić się czy jest tak w rzeczywistości.

Nie musi być to jedyna przyczyna!

-----

Od siebie dodam, że oprócz metod opisanych w wątku Brak dźwięków systemowych, na stronach internetowych, ..., Objawy - możliwa przyczyna - naprawa spotakłem się ostatnio z trojanem, który wgrywał do katalogu z przeglądarką (Opera, FF i IE) pliki setupapi.dll, co powodowało, że dźwięk z flasha nie był odtwarzany (były też problemy z wydrukiem z przeglądarki). Wystarczyło usunąć (lub np. zmienić nazwę) pliku setupapi.dll (ale tylko w katalogach przeglądarek, a nie w windows\system32!) i problem został rozwiązany (szczegóły tutaj).






Użytkownicy przeglądający ten temat: 0

0 użytkowników, 0 gości, 0 anonimowych